我正在使用SQL Server 2008开发人员版.我试图附加AdventureWorks2008数据库.
当我试图附加时,我收到"访问被拒绝"错误.根据事件日志,它来自O/S:
打开失败:无法打开文件D:\ ProjectData\AdventureWorks\AdventureWorksLT2008_Data.mdf,文件编号为0.操作系统错误:5(访问被拒绝.).
我认为"NTFS问题",但系统(和我)修改了对这两个文件的访问权限.
我发现如果我以sa身份登录,我可以成功附加数据库,但我的用户帐户将无法正常工作.
我是我机器上本地管理员组的成员,我在SQL Server实例中担任sysadmins角色.
知道为什么我必须以sa身份登录吗?
我正在尝试在sql server 2012中安装AdventureWorks 2012数据库.我从这个链接获得了mdf文件 - http://msftdbprodsamples.codeplex.com/releases/view/93587
这是我下载的文件的名称 - AdventureWorks2012_Database.zip
我在Windows 7 64位上做这一切.
我收到以下错误:
Attach database failed for Server 'SuperPC\SQL2012'. (Microsoft.SqlServer.Smo)
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=11.0.2100.60+((SQL11_RTM).120210-1917+)&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Attach+database+Server&LinkId=20476
ADDITIONAL INFORMATION:
An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)
Unable to open the physical file "C:\Databases\AdventureWorks2012_Data.mdf". Operating system error 5: "5(Access is denied.)". (Microsoft SQL Server, Error: 5120)
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&ProdVer=11.00.2100&EvtSrc=MSSQLServer&EvtID=5120&LinkId=20476
Run Code Online (Sandbox Code Playgroud)