问题列表 - 第195页

如何分析表、索引使用的空间

我们有一个在过去一年中有机增长的数据库。如何快速分析每个表使用的空间?我们也想考虑索引。

mysql

4
推荐指数
2
解决办法
5740
查看次数

谷歌浏览器:通过 Windows 身份验证

IT 部门正在考虑允许将 Google Chrome 浏览器安装和自动部署到 100 多个桌面。要求之一是传递域凭据。所需的行为与 Internet Explorer 相同。

浏览内网资源时出现问题。需要 Active Directory 身份验证的 Intranet 站点显示“需要身份验证”对话框。

对于每个站点,您必须输入域凭据。

问题:Google Chrome 目前或计划支持直通 Windows 身份验证吗?如果是这样,您如何配置此安全设置?

windows authentication google-chrome single-sign-on passthrough

28
推荐指数
3
解决办法
9万
查看次数

如何 Telnet 到 Pop3 服务器?

我有一个面试,我想玩玩 POP3 和 SMTP 协议。

我正在尝试使用 Microsoft Telnet 命令行程序登录到我的 gmail 的 pop3 服务器帐户,但它不起作用

我正在命令窗口中输入pop.gmail.com 995。我认为它不起作用,因为 Gmail 服务器需要 SSL。我曾尝试使用 Putty 在端口 995 连接到 pop.gmail.com,但这也不起作用。

如果 Microsoft Telnet 或 Putty 不起作用,还有什么会起作用?

谢谢!

pop3 telnet

2
推荐指数
1
解决办法
7579
查看次数

虚拟机内存使用情况未出现在 TaskManager 中

有一些关于 Windows 内存管理的东西,它与 TaskManager 的关系我不明白,我希望有人能启发我。

如果我正在运行虚拟机(不管是 Virtual PC 2007、Virtual Server 2005 还是 VirtualBox,因为它们的行为方式相同)并调出 TaskManager 我可以在进程选项卡上看到 VM 的一些条目,但是内存值相当小(大约 30 MB)。显然,它不包括 VM 本身实际消耗的内存。您可以显示的各种与内存相关的列都没有以不同的方式工作。性能选项卡上的内存使用情况对于包括 VM 在内的总内存使用情况似乎是正确的。

所以我的问题是为什么 VM 的内存使用量(将是 100 MB)没有显示在“进程”选项卡上?

virtualization windows memory task-manager

35
推荐指数
3
解决办法
3万
查看次数

SVN客户端认证错误

当我尝试连接到网络上的 SVN 服务器时,出现以下错误:

无法对服务器进行身份验证:拒绝基本质询

任何人都可以帮忙吗?

svn

11
推荐指数
2
解决办法
3万
查看次数

在互联网上公开数据库服务器的智慧?

我工作的那家小公司的领导层对 SaaS 感到非常兴奋,并正在将我们的产品推向 SaaS 部署 - 我对此感到担忧,因为产品的部分功能基于用户能够使用商业智能针对应用程序的底层数据库编写报告的工具。

当我问到我们计划如何在 SaaS 模型中提供该功能时,我得到了茫然的目光,回答很简单,我们将在互联网上公开数据库服务器,并允许人们查询数据库,就好像它在其中运行一样他们的公司网络。

这吓坏了我,但我不知道我是否只是偏执,或者是否有重要的理由担心。

所以我的问题是:是否可以适当地加强 Oracle 数据库服务器的安全性,以便我们不需要担心它会暴露在 Internet 上的事实?如果是这样,我应该研究哪些资源来学习做到这一点?该数据库将存储我们的客户不想向全世界公开的专有信息,但将这一功能置于 VPN 之后的提议已被明确拒绝。

我对强化 oracle 数据库的搜索几乎包含了“永远不要在防火墙上戳一个洞”这样的语句,所以这里的正确答案可能是“尽快更新你的简历”,但我感谢您提供的任何建议。

oracle security database saas

9
推荐指数
1
解决办法
5721
查看次数

SharePoint 内容数据库的最大大小

昨天在教授 MCM 时与 SharePoint 专家交谈的另一个问题。SharePoint 准则是不支持 100GB 以上的内容数据库。没有进入这些准则背后的原因,我很感兴趣地听到内容数据库更大的比100GB,并与他们您的经验(主要是围绕着性能,灾难恢复,以及医管局供应)。

您设法将 SharePoint 安装推到什么程度?我听说过 > 1TB 内容数据库的二手故事,但我想听听 SharePoint 管理员本人的意见。

感谢您提供的任何信息。

sharepoint sql-server

8
推荐指数
1
解决办法
9413
查看次数

Apache+Tomcat 通信出现问题。不明确的错误信息。关闭托管在 Tomcat 下的网站

设置:
Fedora 8
Apache 2.2.8
Tomcat 5.5.8
Apache 使用 AJP 转发请求。

问题:
经过一段时间后(根本没有常数,可能在一两个小时之间,或者一天或几天之间)Tomcat 将关闭。它要么停止响应,要么提供通用的“服务暂时不可用”。

诊断:
有两台服务器的设置相同。一个是流量较高的网站(每秒几个请求),另一个是低流量网站(每隔几分钟就有几个请求)。这两个网站是完全不同的代码库,但它们表现出相似的问题。

在第一台服务器上,当问题发生时,所有线程都开始慢慢被占用,直到达到限制(MaxThreads 200)。那时服务器不再响应(并且在很长一段时间后出现服务不可用页面)。

在第二台服务器上,出现问题时,请求需要很长时间,完成后您只能看到服务不可用页面。

除了提到 MaxThreads 问题之外,Tomcat 日志没有指出可能导致此问题的任何特定问题。

但是,在 Apache 日志中,我们看到了涉及 AJP 的随机消息。这是我们看到的随机消息示例(无特定顺序):

[error] (70007)The timeout specified has expired: ajp_ilink_receive() can't receive header
[error] (104)Connection reset by peer: ajp_ilink_receive() can't receive header
[error] proxy: AJP: disabled connection for (localhost)
[error] ajp_read_header: ajp_ilink_receive failed
[error] (120006)APR does not understand this error code: proxy: read response failed from 127.0.0.1:8009 (localhost)
[error] ap_proxy_connect_backend disabling worker for (localhost)
Run Code Online (Sandbox Code Playgroud)

我们在更高流量的服务器上注意到的另一件奇怪的事情是,就在问题开始发生之前,数据库查询所用的时间比以前长得多(2000-5000 …

tomcat ajp apache-2.2

22
推荐指数
3
解决办法
8万
查看次数

无法将 MSMQ 消息发送到服务器的第二个 DNS 名称

将此发布在 StackOverflow 上,但我认为它可能与这群人更密切相关。

我在向服务器上的第二个 DNS 名称发送 MSMQ 消息时遇到问题。如果我们为同一台服务器发送 IP,我们很好,但这不是我们在架构上要去的地方。关于为什么 MSMQ 会关心它收到的名称的任何想法?

这是我们的例子:

服务器信息:物理服务器 load-int-01,具有与之关联的第二个 IP 和 DNS 名称。第一个 IP/DNS: load-int-01, 有 IP10.0.10.10第二个 IP/DNS: load-intv, 有 IP10.0.10.20

使用的队列路径格式:

FormatName:DIRECT=OS:load-int-01\private$\MyQueue -> 工作正常

FormatName:DIRECT=OS:load-intv\private$\MyQueue -> 返回以下错误:

队列不存在或您没有足够的权限来执行此操作

我们也尝试过使用 IP 地址,两组 IP 都可以正常工作。

FormatName:DIRECT=TCP:10.0.10.10\private$\MyQueue-> 工作正常FormatName:DIRECT=TCP:10.0.10.20\private$\MyQueue-> 工作正常

domain-name-system msmq

7
推荐指数
1
解决办法
4473
查看次数

从文件系统备份中恢复 PostgreSQL 数据库

我有一个 PostgreSQL 8.3 数据目录备份。我需要将此备份中的数据库复制到新的 PostgreSQL 实例中。由于旧服务器的问题,我无法对数据库进行 pg_dump。

我已经弄清楚哪个目录是有问题的数据库。例如,在 MySQL 中,您通常要做的就是关闭服务器,复制目录并重新启动它,数据库将可用。现在这不适用于 PostgreSQL,我怀疑这是因为该数据库未在 global/pg_database 文件中列出。这个文件似乎是在 PostgreSQL 启动时自动生成的,所以我如何告诉系统数据库在那里?

postgresql disaster-recovery

4
推荐指数
1
解决办法
9585
查看次数